Kitchen Faucet Kepps Plugging Up….

Home Forums Public Forums General Plumbing Kitchen Faucet Kepps Plugging Up….

  • This topic has 2 replies, 2 voices, and was last updated 8 years ago by stjr.
Viewing 2 reply threads
  • Author
    Posts
    • #280126
      maureen kenney

      Hello Everyone! I’m brand new to the Forum and I sincerely hope someone can help. I installed a WaterRidge single level pull-out faucet (#705475)about a year ago (bought the faucet from Costco). The faucet worked great for the first 7 – 8 months. Then suddenly, the faucet stream (hot or cold, didn’t matter) would slow to a trickle, I removed the aerator and found all these tiny white pellets! I cleaned out the aerator and reassembled the faucet and it worked great for a little while. Then the same thing happens again! Now it’s so bad it’s starting to affect the valve body. I know it’s not calcium because I put some of it in CLR and in Vinegar and never got a reaction (no bubbling). And the weirder thing is, NO OTHER FAUCETS in the house have this problem!

      I do have pictures of what I’m getting out of the aerator. Here they are:

      I hope someone has some idea of what’s going on…I’m at a loss.

      Sincerely….

      STJr
      Phoenix AZ

    • #302339
      stjr

      Okay….let’s try THIS link to the picture….

      http://i1283.photobucket.com/albums/a546/stjr/P1040637_zps10a2ad81.jpg

      STJr
      Phoenix, AZ

    • #302340
      stjr

      Okay…I third time is a charm (with the picture)…

      This is what I get out of the kitchen faucet aerator! Gosh I hope someone can tell me what this stuff is!!

      stjr
      Phoenix, AZ

Viewing 2 reply threads
  • You must be logged in to reply to this topic.

Pin It on Pinterest

Share This