Can anyone help? PLEASE?!!

Home Forums Public Forums Drainage & Sewerage Can anyone help? PLEASE?!!

Viewing 3 reply threads
  • Author
    Posts
    • #278987
      andygramm

      We have an awful smell coming from our toilet. I clean it at least once a day, but when the lid is lifted the odor is horrible. This has been going on since last fall when our town (and each home) had a new water line put in. We thought it was the toilet and put in a new one. No help. We put in a new vent with no relief. The only possible thing we can think of is somehow it is the new water line or something being added to the water. If anyone has ANY suggestions, please help…This has frustrated us beyond belief (not to mention the cost of a new toilet and sewer stack).

    • #299747
      mmilner

      Jayne: You state that the odor could be from a new waterline? What does it smell like? Sulpher or a rotten egg odor? let us know.

    • #299748
      jayne

      I am pretty sure it is not a sulphur smell, and it does not seem like rotten eggs either. It is a gaseous odor, and it almost seems to be coming from under the rim. The tank water does not stink. When the toilet is used for a bm, the two “gaseous” odors make a poisonous stench. My parents are on the same water system and we do not notice anything when we use THEIR toilet. I have dumped bleach down the overflow to clean the rim out, and that did not work. Since the tank water and my parents toilet are ok, I guess it is not the new water system. What on earth is causing this?

    • #299749
      Guest

      maybe they tied in your new water line to a force main.

      quote:


      Originally posted by jayne:
      I am pretty sure it is not a sulphur smell, and it does not seem like rotten eggs either. It is a gaseous odor, and it almost seems to be coming from under the rim. The tank water does not stink. When the toilet is used for a bm, the two “gaseous” odors make a poisonous stench. My parents are on the same water system and we do not notice anything when we use THEIR toilet. I have dumped bleach down the overflow to clean the rim out, and that did not work. Since the tank water and my parents toilet are ok, I guess it is not the new water system. What on earth is causing this?


Viewing 3 reply threads
  • You must be logged in to reply to this topic.

Pin It on Pinterest

Share This