Bradford White Water Heater

Home Forums Archives Old Bulletin Board Archives Bradford White Water Heater

Viewing 2 reply threads
  • Author
    Posts
    • #281148
      kltksp

      I have a Bradford White water heater, Model # MITW40L6LN10, which is a direct vent unit. When the water heater turns on the electronic ignition will click three times, the pilot light will then ignite, approx 3 seconds later the burner will light. The burner will stay lit for 2-3 minutes, then go off. Approximately 15 seconds later the electronic ignition will click again starting the whole process over. This will continue until the water is broughtup to the correct temperature. During this time the exhaust fan continues to operate. Im looking for ideas on what could be wrong. Any suggestions will be helpful.

    • #305010
      John Bawol

      There are several posibilities, but the most likely is restricted venting which causes the burner to accumulate exhaust gases until it is extinguished. The blower evacuates the gases and then the burner can relight until the process repeats itself. : I have a Bradford White water heater, Model # MITW40L6LN10, which is a direct vent unit. When the water heater turns on the electronic ignition will click three times, the pilot light will then ignite, approx 3 seconds later the burner will light. The burner will stay lit for 2-3 minutes, then go off. Approximately 15 seconds later the electronic ignition will click again starting the whole process over. This will continue until the water is broughtup to the correct temperature. During this time the exhaust fan continues to operate. Im looking for ideas on what could be wrong. Any suggestions will be helpful.

    • #305011
      John Bawol

      There are several posibilities, but the most likely is restricted venting which causes the burner to accumulate exhaust gases until it is extinguished. The blower evacuates the gases and then the burner can relight until the process repeats itself. : I have a Bradford White water heater, Model # MITW40L6LN10, which is a direct vent unit. When the water heater turns on the electronic ignition will click three times, the pilot light will then ignite, approx 3 seconds later the burner will light. The burner will stay lit for 2-3 minutes, then go off. Approximately 15 seconds later the electronic ignition will click again starting the whole process over. This will continue until the water is broughtup to the correct temperature. During this time the exhaust fan continues to operate. Im looking for ideas on what could be wrong. Any suggestions will be helpful.

Viewing 2 reply threads
  • The forum ‘Old Bulletin Board Archives’ is closed to new topics and replies.

Pin It on Pinterest

Share This