sulphur smell

Home Forums Public Forums General Plumbing sulphur smell

Viewing 4 reply threads
  • Author
    Posts
    • #275238
      MasterPlumbers
      Keymaster

      I have a new house on a well. When I turn on the hot water i sometimes get a smell like sulphur. I have a filter system on it with a pre-filter and carbon filter, 5 micron. Any comments.

    • #291512
      SylvanLMP
      Participant

      GET your water PROFESSIONALLY TESTED ASAP

    • #291513
      GaryPurolite1
      Participant

      Take a look at http://www.ironproblems.com
      Your problem is likely related to either the magnesium anode in the water heater or Iron or Sulfate Reducing Bateria or a combination of the three. I agree with Sylvan’s suggestion also.

    • #291514
      GaryPurolite1
      Participant

      Take a look at http://www.ironproblems.com
      Your problem is likely related to either the magnesium anode in the water heater or Iron or Sulfate Reducing Bateria or a combination of the three. I agree with Sylvan’s suggestion also.

    • #291515
      daveroconn
      Participant

      Occasionally, a hot water heater is a source of hydrogen sulfide odor. The magnesium corrosion control rod present in many hot water heaters can chemically reduce naturally occurring sulfates to hydrogen sulfide. Pleas visit this site it contains more information.
      http://www.ianr.unl.edu/PUBS/water/g1275.htm

      Have you removed the magnesium corrosion control rod from your water heater?

      If removing the rod from the heater does not get rid of the odor, I would suggest getting your water tested to find out if you have a H2S problem in your well. This is a good place to have your water tested
      http://h2otest.com/index.html

      Respectfully David F. Walling

Viewing 4 reply threads
  • You must be logged in to reply to this topic.

Pin It on Pinterest

Share This